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 Getting Started 

Introduction 
Algolab Raster to Vector Conversion Toolkit converts architect, mechanical and various 
technical drawings, maps and other types of line artwork including black and white 
graphics for books and journals from raster to vector formats.  
With Toolkit a paper drawing can be scanned, line artwork automatically recognized and 
represented in a vector format that then can be imported to your CAD or drawing 
program.  
Attention! The quality of recognition is higher for higher resolution. The resolution 400 – 
600 dpi is preferable whenever possible.  
Due to it’s ability to create perfectly looking smooth fine lines and outlines Toolkit is 
especially useful for Cutting, Engraving, Sign Making and other CAD/CAM systems.   
Toolkit is also tailored to digitize drawings including math graph for further use in MS 
Excel and other math programs. See the topic Some Special Types of Digitizing for 
details. 
Toolkit uses the newest technology in order to provide high quality output. Due to this 
even those who have one of high-end products may find that at least for some kind of 
drawings Toolkit provides better quality of the output vector files. So it may be 
reasonable to have Toolkit available. 
Toolkit has the unique special feature to refine curves. So with a proper choice of 
parameters a vectorized drawing composed of curves normally looks better than the 
original one. To see what does it mean one may  want to open samples dolphin.tif and 
bookNervSystem.tif and vectorize them using settings Smooth curves with default values.  
If your scanner is TWAIN compliant then it is possible to scan a drawing directly into 
Algolab Raster to Vector Conversion Toolkit using File=>Acquire menu item. Otherwise 
you may want to scan drawings with the software supplied with the scanner and save 
raster images in one of the raster formats supported by Algolab Raster to Vector 
Conversion Toolkit. 
Algolab Raster to Vector Conversion Toolkit supports the following raster formats: BMP, 
TIFF, JPEG, PNG, PCX, TGA.  
The output vector files can be saved in the following formats: DXF (AutoCAD), AI 
(Adobe Illustrator), EMF ( Enhanced metafile) and WMF ( Windows metafile)  and TXT 
( ASCII XY ) format importable into MS Excel and other mathematical programs. 
Toolkit provides Plot Optimization by sorting the tool path. It increases plotting and 
cutting efficiency and is useful for users of Cutting, CNC and Numeric Control 
applications. 
There are no restrictions on the image size. 
Developers! These who wish to add the raster to vector conversion functionality to their 
products may also want to consider our Raster to Vector Conversion SDK ( software 
development kit ). The raster to vector conversion engines are available as dll, com 
component and ActiveX. Visit our WEB site for details and/or contact us. 
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Installation 
Download the file r2v.exe from our WEB site or from mirror sites, run it and follow 
prompts. It will install the application for an evaluation period of 10 days. After that 
period the “save as” file operation will be disabled. 
All upgrades from versions 1.0, 1.1, 1.2 etc. to the latest version below 2.0 are free of 
charge. So do not forget to visit our WEB site to get the latest version of the program. 

Test 
Open supplied sample raster images, select an appropriate type (architectural, mechanical 
etc.)  and press Vectorize button. There should be color lines over black original image. 
Save the result as a vector file and open it in you CAD or drawing program. 
 

 Raster to Vector Conversion Software Development Kit: 
Dll, ActveX and Com Component  

 
Attention Developers! These who wish to add the raster to vector conversion 
functionality to their products may also want to consider our Raster to Vector Conversion 
SDK ( software development kit ). The raster to vector conversion engines are available 
as dll, com component and ActiveX. Visit our WEB site for details and/or contact us. 

 Step by Step 
 
Recommended Steps 
Step 1. Image acquisition  
Normally the quality of vectorization is higher for higher resolution. So A4 drawings can 
be scanned with resolution 600 dpi. Large format drawings may require lower resolution 
to provide reasonable size of the raster file. 
Step 2. Preprocessing 
The use of preprocessing before vectorization is highly recommended in order to provide 
cleaner vector output. One of the main operations in preprocessing is to remove white 
holes. The simplest way to do this is to use function Raster=>Fill Small Holes. For details 
see the topic Editing Raster Images in this Help. 
Step 3. Selection of Appropriate Settings 
Settings can be selected from Recognition=>Settings dialog box. For some applications 
like architectural there is a named set of default settings with the same name. For other 
ones like Cutting, Engraving, Sign Making and other applications working primarily with 
curves the methods Curves and Smooth curves may be used to start from. These two 
methods differ one from another by the number of Smoothing iterations. A larger number 
provides smoother curves but with larger possible deviation from the original. By 
experimenting with the number of Smoothing iterations one can find appropriate values. 
See the topic Settings in this Help for details. 
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 Depending on the choice of settings in Recognition Parameters dialog box curves can be 
represented by poly lines/arcs or by bezier. In Dxf output format bezier are represented 
by splines.  
Step 4. Output 
For Dxf and Txt ouput formats there are additional options that can be selected from 
File=>Output Options menu item.  

 Editing Raster Images, Preprocessing 

Negate 
To change black to white and vice versa press Raster=>Negate menu item. 

Rotate by Line 
Use Raster=>Rotate by Line menu item or Rotate by Line button. 
This operation corrects small skew. Activate this tool and draw a line from left to right 
along a line on the raster image that should become horizontal. The rotation takes place 
when the mouse button is released. 

Mirror, Rotate Left, Rotate Right 
Use Raster=>Mirror Vertical; Raster=>Rotate Left; Raster=>Rotate Right menu items or 
buttons with similar names. 
These operations provide mirror vertical and 90 degrees rotation to the left and to the 
right. 
Use Raster=>Mirror Vertical; Raster=>Rotate Left; Raster=>Rotate Right menu items or 
buttons with similar names. 
These operations provide mirror vertical and 90 degrees rotation to the left and to the 
right. 

Fill small holes, Fill holes, Clean 
Recommended operations include Fill small holes, Fill holes, Clean. They compose 
some kind of preprocessing that improves the quality of recognition. Usually Clean may 
be used after Fill operations. Every operation can be iterated several times. The minimal 
use of preprocessing supposes use of Fill Small Holes operation. 
Fill small holes  is a recommended operation before any vectorizing. It fills small holes 
that otherwise could change the topology of the image and affect the quality of 
recognition. 
Fill holes is designed for larger holes. Both these operations have few or non side effects 
and may be applied to the image many times in any combination while all holes become 
filled. 

Connect 
Connect is an operation that connects two pixels when the distance between them is 
equal to 1. Use it only when really necessary. If used has to be used before Clean 
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operation. Otherwise Clean can make gaps wider than 1 pixel and Connect will fail to 
connect such pixels.  
Side effect: can connect pixels that are not supposed to be connected. So Fill Holes 
operation should be applied after this operation. Another solution is to use Thin operation 
before connect that reduced number of places where wrong connection could be done. 

Clean 
Clean is a recommended operation. It can affect both black and white pixels. Improves 
the quality of boundaries, reduces noise and fills small holes. It can be repeated as many 
times as needed. 
Side effect: erodes ends making lines shorter. The number of iterations can be chosen as a 
trade between cleaning effect and shortening lines. 

Thicken 
Sometimes Thicken can help in recognition process. 

Thin  
Thin is a simplified version of Thinning operation. 

Crop 
Crop is a standard way to select a part of the image to be vectorized. Use the Arrow 
cursor to select the part of the image and then press Raster=>Crop menu item. 
When several parts of the image should be vectorized one can select the first part, crop it, 
vectorize and save the result as a vector file. By using UnDo twice one can get the image 
before Crop and repeat operations with other parts. 

External Raster Editor 
External Raster Editor can be called from Raster=>External Editor menu item. By 
pressing “run”. A currently selected editor will be called. By default it is MS Paint. To 
change the raster editor press “select” and browse to find an executable (*.exe) file of the 
desirable editor. 
In the default case when the editing has been done the user closes the External Editor. On 
close it prompts user to save changes. Press Yes and that’s it. 
Some more details for those who use not default external raster editor. 
When Toolkit calls the external editor it transfers to the editor the current image over the 
exchange bmp file ____exchangeBmp.bmp created by Toolkit. Then one can edit the 
image in the external editor and when done save the result in the file 
____exchangeBmp.bmp. Normally it can be done automatically by closing the external 
editor. At that moment the editor prompts to save changes. One select Yes and editor 
updates the file ____exchangeBmp.bmp, so there is no need to seek that file on the disk 
manually. Some editors require user to press Save item in the File menu item. 
At that point user should close the external editor or at least the image in it that let 
Toolkit to gain full control over the exchange image. 
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Toolkit updates it’s image automatically when External Editor saves it’s results in the file 
____exchangeBmp.bmp. 
 

 Settings 
 
The settings can be reached from Recognition Menu item. First dialog shows all 
recognition types to choose from Architectural, Mechanical etc.  
To change parameters of a selected recognition type press Edit button. It will open the 
Recognition Parameters dialog. Any change in these parameters for one recognition type 
does not affect the parameters for another recognition type. Each recognition type is fully 
defined by these parameters. 

Recognition Parameters Dialog 
In this dialog one can choose recognition parameters for the selected recognition type. 
First one can choose vectorization by center lines or by outlines.  
For outlines the parameter "Min pixel length"  enables one to eliminate outlines which 
length in pixels is less than a selected value. For centerlines the "Min pixel length" 
parameter serves to eliminate artifacts. It is used  to remove centerlines which connect to 
another centerlines only at one end and have pixel length less than a selected value. The 
side effect of a large value for this parameter may be in a loss of details. 
There are three elements that can be chosen for recognition: lines, arcs and curves. 
Lines. Additional options: horizontal and vertical, 45 degrees. If for instance 45 degrees 
option is selected then the special check will be done for lines if they can be identified as 
having 45 degrees inclination. 
Arcs. Circles are included as arcs with equal ends. No additional options available. 
Curves. There are several additional options to choose from for Smoother and curve 
representation. 
Smoother is an important part in the curve enhancement mechanism. At each iteration it 
re-shape the curve to make it smoother. Number of iteration defines the depth of re-
shaping. Each iteration can slightly shift the curve. So one may trade accuracy against 
smoothness. When a high accuracy required a few (1-2) iterations may be preferred. To 
provide effect of “Fine curves” 10-20 iterations may be an appropriate choice. 
Another way to prevent shift is to select option “Curve constrained”. This will keep the 
curve on the black area for shift tolerance 0 or permit is 1 pixel close to the black area for 
tolerance 1. The side effect of “Curve constrained” option is that it may affect 
smoothness. So it is better doing not use it when trying to obtain “Fine curves”. 
Curves representation. There are three options: by lines, by Bezier polynomials and by 
poly lines/arcs. 
No further options are available for representation by lines. 
By Bezier. Tolerance in pixels defines the precision with which Bezier polynomials 
represent curves. More tolerance produces less Bezier points. Inner control points are 
shown in a different color than end points. 
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Conjugation tolerance is applied when one curve at it’s end point is tangent to another 
curve at it’s inner point. Less tolerance gives smoother conjugation but it can also shift 
the intersection. 
By Poly lines/arcs. In this case Beziers are approximated by arcs and lines. This 
transformation of Beziers into arcs and lines is controlled by the parameter Arc tolerance. 
Larger tolerance gives less arcs. 
There are settings that do not depend on the type of element. 
Angle sensitivity: more sensitivity is more angle points will be detected. 
Intersect along tangents controls X-type intersections. When unchecked a different 
simplified mechanism is used for lines to cross intersections. It may be reasonable to try 
in unchecked mode when many poorly defined intersections are present like on a map 
with several families of intersecting curves.  
Preprocessing: Fill Holes, Connect, Clean, Thicken and Thin 
Recommended operations include Fill small holes, Fill holes, Clean. They compose 
some kind of preprocessing that improves the quality of recognition. Usually Clean may 
be used after Fill operations. Every operation can be iterated several times. The minimal 
use of preprocessing supposes use of Fill Small Holes operation. 
Fill small holes  is a recommended operation before any vectorizing. It fills small holes 
that otherwise could change the topology of the image and affect the quality of 
recognition. 
Fill holes is designed for larger holes. Both these operations have few or none side 
effects and may be applied to the image many times in any combination while all holes 
become filled. 
Connect is an operation that connects two pixels when the distance between them is 
equal to 1. Use it only when really necessary. If used has to be used before Clean 
operation. Otherwise Clean can make gaps wider than 1 pixel and Connect will fail to 
connect such pixels.  
Side effect: can connect pixels that are not supposed to be connected. So Fill Holes 
operation should be applied after this operation. Another solution is to use Thin operation 
before connect that reduced number of places where wrong connection could be done. 
Clean is a recommended operation. It can affect both black and white pixels. Improves 
the quality of boundaries, reduces noise and fills small holes. It can be repeated as many 
times as needed. 
Side effect: erodes ends making lines shorter. The number of iterations can be chosen as a 
trade between cleaning effect and shortening lines. 
Sometimes Thicken can help in recognition process.  
Thin is a simplified version of Thinning operation. 
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 Output 

Output formats 
There are five output vector formats: DXF (AutoCAD), AI (Adobe Illustrator), EMF 
(Enhanced metafile ), WMF (Windows metafile) and TXT ( XY ASCII ) format 
importable into MS Excel and other mathematical programs. 
DXF.  If the output does not contain splines the output format corresponds to AutoCAD 
12, otherwise it corresponds to AutoCAD 14. There are no splines in output if the option 
Splines is not selected in Recognition Parameters dialog box. Some CAD programs do 
not read splines so the option Splines should be unselected in such case. The dialog box 
Recognition Parameters can be reached from Recognition=>Settings=>Edit menu item. 
If the option Poly lines/arcs is selected then beziers are converted into poly lines 
composed of arcs and lines. If the option Splines is selected then beziers are represented 
by splines in output DXF file. The units inch or cm of dxf file can be selected from 
File=>Output Options dialog box.  
TXT. The output file is a text file composed of lines. Each line includes X and Y 
coordinates of a point so it is a XY format. An XY file can be imported into MS Excel 
and other mathematical programs. One can resize,  choose origin and select linear or 
logarithmic coordinate axis using Vector=>Scale txt Output menu item. The density of 
output points and type of delimiter can be selected from File=>Output  Options menu 
item. 
This format supports use of Toolkit to digitize mathematical graphs and any other 
drawings that then can be used in XY vector format.  
If the file contains more than one curve they are delimited by an empty line in txt file. 
See more about XY output  in the section Scale XY ASCII Output formats and in the 
section Some Special Types of Digitizing in this Help. 
Scale XY ASCII Output 
Load an image. Then use Vector=>Scale txt XY Output menu item to activate the dialog 
Scale txt XY ASCII Output .  
In this dialog the column Pixel indicates the position on the raster image and the column 
Value indicates the value in the output file which corresponds to this position. The 
column Set enables user to select the pixel position on the raster image.  
Example. Suppose we need to digitize a math graph. First let us work with min row in X 
coordinate area. It defines the minimal X pixel position on the raster image and the value 
in output file which should correspond to this pixel position.  
Click on Set button that is to the right from min in the X coordinate area and move cursor 
to the image. The shape of the cursor is changed. Click on the point of the graph that has 
the minimal X coordinate. A red mark will remain at that point on the screen. Now type 
into the Value column edit box ( located in the row min) the value which you wish to 
correspond to Xmin in output file. 
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Now go to the max row, click button Set and place the cursor at the point of the graph 
with the maximal X coordinate. Then put cursor in the edit box Value and enter the value 
in the output file which should correspond to this pixel. 
Do the same thing with Y coordinate. Then press OK button. Save the vector file in txt 
format and check if scaling is correct by importing the file into MS Excel or other 
application or directly opening the txt file in NotePad or other word processor. 
To use logarithmic scale check logarithmic checkbox. 
There are some limitations on values that can be accepted. The minimal value must be 
less than the maximal one. If the logarithmic scale is selected then all values must be 
positive. 
There is an alternative way to select position of Xmin and Ymin with the help of Select 
origin button. 
Each time a file with a new name is opened the scaling parameters are re-initialized with 
default values. The default values correspond to the size of the image in centimeters. The 
default pixel positions of Xmin = 0 and Ymin = 0 are at the bottom left corner of the 
image. The default pixel positions of Xmax and Ymax are at the top right corner. 
See more about XY output in the section Output formats and in the section Some Special 
Types of Digitizing in this Help. 
 

 Recognition 
 

Methods 
There are the following recognition methods: 
Architectural 
Mechanical 
Map 
Lines, arcs and circles 
Lines and arcs 
Curves 
Math graphs 
Smooth curves 
Outlines 
Smooth outlines 
User1 
User2 
To choose the method use Recognition=>Settings menu item.   
Each one of these methods is a set of settings that can be edited by the user. The name of 
the set only indicates that the default values of these settings are chosen to fit the 
particular type of applications. 
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User1 and User2 are supplied only for convenience. For example the user may want to 
edit the settings for the type of applications of interest like Map or set appropriate values 
to User1 set of settings and use User1 method instead of Map. 

Batch Mode 
The BATCH MODE allows to vectorize the multiple number of raster images into *.dxf 
vector format. 
The BATCH MODE DIALOG can be reached from the RECOGNITION menu clicking 
the option BATCH MODE. 
To choose raster files for vectorizing press the button ADD. The raster file appears in the 
left section of dialog window. In the right section of the dialog window,  automatically 
appears the name and the location of the output file.  
To organize the list of raster files repeat pressing ADD button and select raster files to be 
vectorized. 
Vector files would be saved with corresponding file name and in the same directory as 
the input raster file. File names would be identical with raster but they would have 
extensions *.dxf. The user can change the output file name and location by pressing the 
button EDIT or by double clicking the file name in the dialog window. 
Press button DEL to remove  files from the processing list. 
It is possible to save the list of files on the disk in special text format with *.btc file 
extension for the purpose of future processing. Press SAVE button to store it. List loading 
from the file can be done by pressing LOAD button. 
After the list is organized press VECTORIZE button to implement vectorization. If the 
vector file already exists it is possible to rename or overwrite it during processing. 
To exit BATCH MODE press CANCEL. 

 

 Smooth Curves 

Smooth Curve Creation 
his Toolkit has the unique feature to create smooth perfectly looking curves. It even 
corrects them so that the resulting curves tend to have more mathematically regular form. 
The supplied sample dolphin.tif illustrates this capability. One may want to open it and 
vectorize using the settings Smooth curves with default values. To select the settings use 
Recognition=>Settings dialog box. To edit settings press Edit in that dialog box. This 
opens Recognition Parameters dialog box. 
The effect of curve smoothing is provided in the most with the operation Smoother 
repeated 10 – 20 times. The number of iterations for smoother can be set in Recognition 
Parameters dialog box. 
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The scan resolution is also essential for the output quality. The resolution 600 dpi or 
higher may be tried first to determine an appropriate value. 
The smoothing can shift curves. So one may want to reduce the iteration number of 
Smoother to get more precise result.  
When curves have gaps the Smoothing operation is supplied before performing gap 
jumps. So Smoother does not smooth the whole curve but only continues parts. To 
provide smoothing the whole curves one may want to fill gaps before vectorization at the 
step of raster image editing.  
For more details see topics Settings and Step by Step. 
Recommended Steps in Math Graph Digitizing 
Toolkit supports vector output format ASCII XY especially to digitize math graphs and 
for similar tasks. There are several steps in the digitizing. 
If the image is not scanned yet then appropriate settings of scanner may help to improve 
quality. The recommended resolution is 600 dpi or higher.  
To digitize a math graph it is reasonable to remove from raster all other black parts like 
grid,  text etc., so that only the graph itself remains.  
It is strongly recommended to fill holes that can be done using Raster=>Fill Small Holes 
or Raster=>Fill Holes operations repeated appropriate number of times untill all white 
holes are filled. 
If the graph contains gaps then one may try two approaches to fill these gaps. The first 
approach is in use Raster=>Thicken operation appropriate number of times.  Another 
approach is to set an appropriate value for the parameter gap jump. It may be helpful to 
take into account that gap jumps are provided after smoothing that is why the first 
approach may provide smoother results. 
See more about preprocessing in Editing Raster Images section of this Help. 
When the image has been prepared for vectorization select appropriate method  using 
Recognition=>Settings menu item. The Math Graphs method can be chosen. Then press 
F12 or  Vectorize toolbar button to vectorize the image. 
With the help of the Hot Key  R or from menu View=>Show Raster one can toggle the 
raster to see the vectors. At this point adjustments to settings can be done to improve the 
quality. If the vector should be more smooth then increase the parameter Iteration number 
for Smoother in Recognition Parameters dialog box, press General=>UnDo to cancel 
previous vectorization and run vectorization again.  The dialog box Recognition 
Parameters can be reached from Recognition=>Settings=>Edit menu item.  
If the vector should be more precise then reduce the number of iterations for Smoother. 
The parameter Min pixel length can be used to avoid artifacts if any occurs. 
To scale ASCII XY vector output use Vector=>Scale txt XY Output menu item.  
The vector file can be saved in txt format that is an ASCII XY format readable by MS 
Excel and other mathematical programs. The density of points in the output file can be 
changed from File=>Output Options=>Txt menu item. 
See more about XY output in the section Output of this Help. 
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 Some special Types of Digitizing 
 

Recommended Steps in Math Graph Digitizing 
Toolkit supports vector output format ASCII XY especially to digitize math graphs and 
for similar tasks. There are several steps in the digitizing. 
If the image is not scanned yet then appropriate settings of scanner may help to improve 
quality. The recommended resolution is 600 dpi or higher.  
To digitize a math graph it is reasonable to remove from raster all other black parts like 
grid,  text etc., so that only the graph itself remains.  
It is strongly recommended to fill holes that can be done using Raster=>Fill Small Holes 
or Raster=>Fill Holes operations repeated appropriate number of times untill all white 
holes are filled. 
If the graph contains gaps then one may try two approaches to fill these gaps. The first 
approach is in use Raster=>Thicken operation appropriate number of times.  Another 
approach is to set an appropriate value for the parameter gap jump. It may be helpful to 
take into account that gap jumps are provided after smoothing that is why the first 
approach may provide smoother results. 
See more about preprocessing in Editing Raster Images section of this Help. 
When the image has been prepared for vectorization select appropriate method  using 
Recognition=>Settings menu item. The Math Graphs method can be chosen. Then press 
F12 or  Vectorize toolbar button to vectorize the image. 
With the help of the Hot Key  R or from menu View=>Show Raster one can toggle the 
raster to see the vectors. At this point adjustments to settings can be done to improve the 
quality. If the vector should be more smooth then increase the parameter Iteration number 
for Smoother in Recognition Parameters dialog box, press General=>UnDo to cancel 
previous vectorization and run vectorization again.  The dialog box Recognition 
Parameters can be reached from Recognition=>Settings=>Edit menu item.  
If the vector should be more precise then reduce the number of iterations for Smoother. 
The parameter Min pixel length can be used to avoid artifacts if any occurs. 
To scale ASCII XY vector output use Vector=>Scale txt XY Output menu item.  
The vector file can be saved in txt format that is an ASCII XY format readable by MS 
Excel and other mathematical programs. The density of points in the output file can be 
changed from File=>Output Options=>Txt menu item. 
See more about XY output in the section Output of this Help. 
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 Ordering, Registration, Support and Contact Information 
 

How to order 
To order a license for Algolab Raster to Vector Conversion Toolkit click on Help menu 
item of the program and press Order License button.  
You will reach RegSoft WEB page which provides payment transactions for Algolab 
Raster to Vector Conversion Toolkit. There you will find all available options: online 
purchase with Credit Card, Fax Ordering, Postal Mail, Phone, and Purchase Order. There 
is a link to RegSoft’s home page as well. RegSoft is the largest provider of software 
purchase transactions. The same WEB page of RegSoft can be also reached from our 
WEB site.  
Normally within 12 hours after the payment transaction we will send the registration key 
by e-mail. 

Registration 
When you by Algolab Raster to Vector Conversion Toolkit you are automatically 
supplied with the registration information which is sent to you by e-mail within 12 hours 
after payment.  
Open the registration dialog from Help=>Enter Registration Information menu item of 
the program and fill appropriate fields with registration information that was sent to you. 
To avoid typos it is better to use Copy and Past operations rather than re-typing. 
The notification “Successful Registration!” confirms the registration. After that the 
program becomes fully functional. 

Technical support 
In the case of any question or problem that you cannot resolve with reference to this 
Help, please contact us for free technical support. 

Contact 
Mail:   AlgoLab 

345Hudson Dr. 
London, ON, 
N5V 1E4 CANADA 
 

WEB:  http://www.algolab.com 
 

E-mail: 
 

info@algolab.com 

Telephone: (519) 457 7789 
Fax: (519) 457 0556 
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